Приложение устанавливается, но не запускается

ios

#1

Кто-нибудь сталкивался с тем, приложение требует, для установки минимальной версии iOS 11, а для запуска iOS 12 ?
В итоге приложение сворачивается.
В проекте нигде не указано, что нужна минимальная версия iOS 12.

Xcode пишет:
Sorry, “” cannot be run on this version of iOS. Qt requires iOS 12.0.0 or later, you have iOS 11.4.1.

Не знаю, можно писать здесь название приложения или будет сочтено за рекламу.

Грешил на библиотеки , но там тоже не нашел требований iOS 12, да и в Podfile platform :ios, ‘11.0’

Благодарен за любой ответ!


#2

а что за библиотека?


#3

Какой версией xCode вы пользуетесь?


#4

Xcode Version 12.5.1 (12E507)
также пробовал на Xcode 12.4 (12D4e)


#5
Podfile

pod ‘AFNetworking’, ‘~> 2.7.0’, :subspecs => [‘Reachability’, ‘Serialization’, ‘Security’, ‘NSURLSession’]
pod ‘JASidePanels’, ‘~> 1.3.2’
pod ‘Reachability’, ‘~> 3.1.1’
pod ‘UIAlertView-Blocks’, ‘~> 1.0’
pod ‘UIActionSheet-Blocks’, ‘~> 1.0.1’
pod ‘DACircularProgress’, ‘~> 2.2.0’
pod ‘FFCircularProgressView’, ‘~> 0.4’
pod ‘FormatterKit’, ‘~> 1.8.0’
pod ‘SWTableViewCell’, ‘~> 0.3.7’
pod ‘RegexKitLite’, ‘~> 4.0’
pod ‘MBProgressHUD’, ‘~> 0.9.1’
pod ‘CocoaSecurity’, ‘~> 1.2.4’
pod ‘TPKeyboardAvoiding’, ‘~> 1.2.6’
pod ‘HTAutocompleteTextField’, ‘~> 1.3.1’
pod ‘MaterialComponents/TextFields’, ‘~> 120.0.0’
pod ‘BRCybertron’, ‘~> 1.1.1’
pod ‘MCBinaryHeap’, ‘~> 0.1’
pod ‘TTRangeSlider’, ‘~> 1.0.6’

и


#6

thanks for the awesome information.


#7

было что-то похожее. Судя по сообщению об ошибке - " cannot be run on this version of iOS. Qt requires iOS 12.0.0 or later, you have iOS 11.4.1." возможно изначально приложение создавалось в более поздней версии Swift, а запускалось в данном случае в более ранней версии.