Гиперссылка в Swift

swift4
ios
swift
xcode

#16

Вы включали разрешение трафика в info.plist?


#17

Нет, не включал. А как именно называется в info.plist?


#18


#19

где две стрелочки вниз и вверх туда наведите (на любой параметр) - появится плюс: добавляете параметр App Transport Security Settings. Далее внутри него добавляете Allow Arbitrary Loads in Web Content и ставите ему YES

Там всего 3 параметра для разных типов загрузок - разберётесь ))


#20

Для открытия просто ссылки явно проще UIApplication.shared.open (1 строка кода) :slight_smile: она и так встроенный браузер открывает )) Единственный минус - вне приложения ))


#21

так запрос идет на https.разве нужно ставить Allow Arbitrary Loads?


#22

Да вроде нет ))) Вы правы ) Тогда у товарища @DM45019 ошибка в ссылке :slight_smile:


#23

сайт вроде рабочий, проверил в браузере


#24

Как правильно писать вопросы


#25
if let url = URL(string: "http://yandex.ru") {
                    UIApplication.shared.open(url, options: [:], completionHandler: nil)
                }

Вот это отлично работает у меня на симуляторе. Ошибка то КАКАЯ у вас?

И да: измените название темы на адекватное!


#26

закинул строку в свой WKWebView с Allow Arbitrary Loads в true/false


все грузится без проблем


#27

Почему-то у вас не видно доп.плюшек сайта. типа звонка …

аналогично всё работает ))


#28

я вообще транспортСекьюрити удалил - всё работает.

@DM45019 , проверьте ещё раз:

  1. правильность привязки класса к контроллеру
  2. потерянные связи - вылетает скорее всего из-за них

#29

да, кнопки звонка нет. это уже вопрос верстки


#30

Я к тому, что странно в ВэбКите нет элементов, которые есть во встроенном браузере… Или это вопрос настройки вэбКита?


#31

Всем спасибо, всё заработало!


#32

не знаю, все может быть. может более опытные объяснят в чем может быть дело


#33

Если мне не изменяет память, то WKWebView по дефолту идет с отключенными скриптами.
Пропишите allowJavascript = true, вроде так пишется.


#34

все что есть у WKWebView по Javascript


#35

Пардон, у меня уже все смешалось, это в Андроиде так.